CVE-2026-70651
Publication date 20 August 2026
Last updated 3 November 2026
Ubuntu priority
Description
libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, libvips built without libtiff support but with ImageMagick support can overflow the combined frame height while loading a crafted multi-page TIFF through VipsForeignLoadMagick. The vulnerable calculations in libvips/foreign/magick6load.c and libvips/foreign/magick7load.c multiply the per-page Ysize by n_frames without a checked bound, which can cause a heap buffer over-read and process crash. Most package-manager builds include libtiff and do not use this affected fallback path. This issue is fixed in version 8.18.3.
Status
| Package | Ubuntu Release | Status |
|---|---|---|
| vips | 26.10 stonking |
Not affected
|
| 26.04 LTS resolute |
Fixed in 8.18.0-1ubuntu0.1~esm2
|
|
| 24.04 LTS noble |
Fixed in 8.15.1-1.1ubuntu0.1~esm2
|
|
| 22.04 LTS jammy |
Fixed in 8.12.1-1ubuntu0.1~esm3
|
|
| 20.04 LTS focal |
Fixed in 8.9.1-2ubuntu0.1~esm2
|
|
| 18.04 LTS bionic |
Fixed in 8.4.5-1ubuntu0.1~esm2
|
|
| 16.04 LTS xenial |
Fixed in 8.2.2-1ubuntu0.1~esm1
|
Get expanded security coverage with Ubuntu Pro
Reduce your average CVE exposure time from 98 days to 1 day with expanded CVE patching, ten-years security maintenance and optional support for the full stack of open-source applications. Free for personal use.
Get Ubuntu Pro 30-day free trialSeverity score breakdown
CVSS version: CVSS v4.0
Base score
6.9 · Medium
Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N
References
Related Ubuntu Security Notices (USN)
- USN-8994-1
- libvips vulnerabilities
- 3 November 2026